Unable to install FDK 4.6.1

After installing FDK 4.3.2 as directed on the Developers documentation (https://developers.freshservice.com/docs/quick-start/#install_the_sdk), the version command noted I was not running the latest version of the FDK.

Figuring I should probably be on the latest version, I attempt to install the latest version of the FDK using the following command:

sudo npm install https://dl.freshdev.io/cli/fdk-4.6.1.tgz -g

However, during installation, I'm receiving quite a few notices, including:

npm WARN deprecated json-schema-faker@0.5.0-rc13: Broken not support

npm WARN deprecated circular-json@0.3.3: CircularJSON is in maintenance only, flatted is its successor.

npm WARN deprecated nomnom@1.5.2: Package no longer supported. Contact support@npmjs.com for more info.

npm WARN deprecated cryptiles@2.0.5: This version is no longer maintained. Please upgrade to the latest version.

npm WARN deprecated boom@2.10.1: This version is no longer maintained. Please upgrade to the latest version.

npm WARN deprecated hoek@2.16.3: This version is no longer maintained. Please upgrade to the latest version.

There are two bigger problems that appear to be preventing the installation of the latest FDK:

/usr/local/bin/fdk -> /usr/local/lib/node_modules/fdk/index.js

> jsonpath@1.0.0 postinstall /usr/local/lib/node_modules/fdk/node_modules/jsonpath

> node lib/aesprim.js > generated/aesprim-browser.js

sh: generated/aesprim-browser.js: Permission denied

npm WARN ajv-keywords@2.1.1 requires a peer of ajv@^5.0.0 but none is installed. You must install peer dependencies yourself.


npm ERR! errno 1

npm ERR! jsonpath@1.0.0 postinstall: `node lib/aesprim.js > generated/aesprim-browser.js`

npm ERR! Exit status 1

npm ERR! 

npm ERR! Failed at the jsonpath@1.0.0 postinstall script.

npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

The above is occurring using Node 10.15.0 on macOS 10.14.2 Mojave.

To narrow down the issue, I tried installing the latest FDK on a fresh install of Debian 9.6 using Node 10.15.0. When doing so, the same issue occurs. (See attached.) It happens without sudo and using sudo.

Being fairly new to Node, I'm not sure where to start on troubleshooting this. Is this an issue with this specific version of Node? Is it an error in the latest FDK?

1 person has this problem

Same issue when moving from 4.5.1 to 4.6.1.  However I can reinstall 4.5.1 and every works OK, but I regularly get prompts to upgrade fdk whenever I run it.


Hi Travis,

 FDK requires node v6. Can you try installing fdk-4.6.1 using node v6? Please let me know if you face the same problem with fdk installation with node v6.

I am running node.js version v8.11.4.  So not sure what you mean by v6.  Please provide the full node.js version number.

I installed Node.js 6.16.0 in Debian 9.6 and then installed FDK 4.6.1. While it appears to have installed successfully, there are still quite a few warnings about packages being deprecated or requiring peer to a package. (See attached.)

This is where I was confused. Per the documentation on https://developers.freshservice.com/docs/quick-start/#install_node, it states the following:

"You will need to install Node.js to use Freshworks CLI. You can install node.js from here (any version below 6.10 will not be supported)."

The way this is worded, it sounds like any version of Node above 6.10 will work. However, if the FDK requires specifically the 6.x series of Node to be installed, then this needs to be much more clearly stated on the install instructions. Otherwise, people are going to install more recent versions. (Much like myself and David.)

So that leaves me with a couple of things:

1. The instructions need to be clearer about which version of Node is required / supported.

2. A clearer understanding on if all the WARN messages are expected and will not affect the use of the FDK.


Hello Travis and David.

Apologies for all this confusion. Unfortunately, the instructions in our Freshservice developer documentation is not as clear as what we specify here - https://developer.freshdesk.com/v2/docs/quick-start/#install_node

What we really mean is that only Node versions 6.10.x are currently supported.

We will address the documentation to be much clearer. Thank you for the feedback.

We will look at the warnings closely as well and address them.

Do let us know if there are other points you think we could address.

1 person likes this

Login or Signup to post a comment

Sign up for Freshsales today

Start your 30-day free trial. No credit card required. No strings attached.

Start Free Trial